Bose Solo TV Reparatur

Das Fernseher nicht den besten Klang haben ist gut bekannt, dieses Problem soll die Bose Solo tv soundbar lösen. Auf der Suche nach einem defekten Exemplar ist mir relativ schnell aufgefallen, dass es sehr viele Soundbars mit sehr ähnlichen Defekten gibt.

Was ist mit dem Ding?

Der defekt äußert sich dadurch, dass das Gerät sprichwortlich keinen Mucks mehr macht. Beim Einstecken des Netzsteckers hört man nicht das gewohnte Bubub und beim betätigen der Powertaste auf der Fernbedienung leuchtet nicht die Grüne LED an der Front des Gerätes.

Erste Lösungsansätze

Die Fehlersuche beginnt man am besten beim Netzteil, denn die Fehler dort kann man relaiv schnell finden und beheben, da die Bauteile (meistens) keine vollintegrierten Schaltkreise sind, sondern diskrete Standardbauteile mit öffentlich zugänglichen Datenblättern.

Leider war das Netzteil vollkommen in ordnung, denn bei der Batterie an Elkos kamen schön konstante 24V an. Mist.

Dann habe ich im Internet verschiedene Videos gesehen, in denen eine Fehlersuche durchgeführt und auch einige Geräte repariert wurden.

Die erfolgsversprechendste Lösung für dieses Problem schien die stabilisierung der Spannung der 3,3V Rail zu sein, diese ist die Spannungsversorung für den Hauptcontroller. Also habe ich zwei Elektrolytkondensatoren direkt an die 3,3V Rail gelötet und siehe da, es ging wieder. Und wenn sie nicht gestorben ist, dann lebt sie auch noch heute…. tja, aber sie ist wieder ins Koma gefallen, und das ganze zwei Tage später.

Weitere Fehlersuche

Also was für einen Giftapfel hat das Ding denn jetzt gefressen?
Ich habe die Fehlersuche mit dem Oszilloskop fortgesetzt und die 3,3V Rail genau unter die Lupe genommen.

Was bei einer Fehlersuche aber unerlässlich ist: sich einen Überlick verschaffen.

Die Platine

Es ist eine 3- oder Mehrlagige Platine die von beiden Seiten mit SMD und THT Komponenten bestückt ist. Das Netzteil ist von mit einem Metallgehäuse umschlossen, das eine Störung der Audioelektronik verhindern soll. Der Hauptcontroller mit allen Peripheriechips sitzt in einem weiteren Metallgehäuse.

Die Steuerelektronik

In der Steuerelektronik (so habe ich es jetzt einfach mal genannt) befindet sich der Hauptcontroller(DSP) mit ein bisschen Peripherie und, vorallem, einige Step-Down Converter die unter anderem die Spannungsversorgung für den DSP darstellen.

Die Converter

Es sind drei an der Zahl, mit 1,2V, 1,8V und 3,3V Ausgangsspannung. Der 1,8V ist ein einfacher Lienarregler, was der versorgt ist erstmal unerheblich.

Der 1,2V Regler ist der gleiche wie der 3,3V, nämlich ein TPS62110. Das ist ein Buck-converter von Texas-Instruments(YAY) dessen Datenblatt wunderschön ausführlich ist und die Fehlersuche verienfacht.

Die 3,3V Rail

Endlich da wo ich hin wollte. Die 3,3V Rail besteht aus dem Regler(TPS62110), einer Induktivität, einigen Keramikkondensatoren und einem Elko. (natürlich auch Widerständen, Kupfer und Verbrauchern, aber EGAL)

DIE Fehlersuche

Wie schon erwähnt habe ich die Fehlersuche mit dem Oszilloskop fortgesetzt, dazu habe ich die 3,3V Versorgung aufgezeichnet.

Was sieht man jetzt hier?

Das ist eine Aufzeichnung der 3,3V Versorgungsspannung mit einer Länge von 5 millisekunden. Man sieht einige Spitzen auf der Spannung, diese entstehen durch die Schaltvorgänge vom Step-Down Converter und werden durch die 10uH Induktivität leider nicht gänzlich gefiltert, was aber normal ist. Zum filtern gibt es Keramikkondensatoren, in dem Fall auch nicht wenige.

Was der DSP genau für ein Problem mit der Spannung hat ist eine Frage die ich nicht beantworten kann. Es kann sein, dass er durch Alterung vielleicht anfälliger gegenüber Rippelspannung geworden ist.

Die Fehlersuche habe ich dann mit einem Labornetzteil fortgesetzt, indem ich die Induktivität heruntergelötet habe und die 3,3V Versorgung mit dem Labornetzteil vorgenommen habe. Dann ging das Gerät auch wieder, ich dachte das lag daran, dass das Labornetzteil keine Rippelspannung ausgibt.

Der nächste logische Schritt war für mich dann den TPS62110, seine 10uH Induktivität und alle Kondensatoren auszutauschen, da ich einfach mal darauf getippt habe, dass der Konverter samt Peripheriebauteile der Grund dafür ist, dass der DSP zu viel Rippelspannung abbekommt.

Nachdem ich das alles getauscht habe ging allerdings immernoch nichts.
MIST.

Also wird der Grund dann wohl eher beim DSP liegen, der mit der Zeit anfälliger für Rippelspannung wird.
Die Lösung wäre dann, die Spannung so glatt wie möglich zu bekommen um das Leben des DSP zu verlängern.

Zum Glück ist das Datenblatt des TPS62110 so schön umfangreich, wodurch sich schnell Stellschrauben finden lassen, den Regler stabiler zu machen.

Eine dieser Stellschrauben ist ein Bypasskondensator für den Spannungsteiler am Feedback-Eingang.

Der Fix

In der Zwischenzeit hatte ich mir schon eine zweite Soundbar gekauft, um sie für die Fehlersuche zu nutzen und wollte dort einen Bypasskondensator einlöten, dabei habe ich vermutlich einen Feedbackwiderstand zerstört.
Als ich den Stecker dann eingesteckt hatte, ging die Soundbar an, ich hab mich schon gefreut, doch dann habe ich die Ausgangsspannung des Reglers gemessen und musste mit Erschrecken feststellen, dass diese bei 5,5V lag. Also habe ich mit Eile den Stecker wieder ausgesteckt und mich dann erstmal gewundert.

Der DSP scheint doch ziemlich spannungsfest zu sein, meine früheren Erfahrungen mit 5V an 3,3V Komponenten waren doch eher…rauchig.

Also habe ich ein Experiment gemacht und das Labornetzteil wieder angeschlossen um zu testen, ab welcher Spannung der DSP bootet. Das hat er ab ca. 4,2V getan, also habe ich die Feedbackwiderstände so ausgetauscht, dass der Konverter nun 4,3V ausgibt und siehe da, die Soundbar geht zuverlässig an und läuft problemlos.

Was war jetzt das Problem?

Zusammenfassend würde ich sagen, dass das Problem irgendwie beim DSP liegen muss. Da er bei normaler Spannungsversorgung nicht bootet, aber bei Überspannung (noch) nicht kaputt geht ist vielleicht an irgendeiner Stelle ein Spannungsfall? Der müsste theoretisch innerhalb des DSP passieren, da am (vermutlich) VCC keine maßgeblich geringere Spannung anliegt als der Konverter ausgibt.

Wie kann ich die Soundbar reparieren?

Diese Reparatur funktioniert bei folgenden Symptomen:
– beim einstecken des Netzsteckers kommt nicht der Bup-Bup Ton
– das grüne Licht geht nicht an wenn man die Soundbar über die Fernbedienung einschalten möchte
– bei eingestecktem Netzstecker kommt ein hochfrequentes piepen aus dem Gehäuse (nicht aus den Lautsprechern)

Folgende Teile werden benötigt:
– 0403 oder 0604 SMD Widerstände mit 33kOhm und 100kOhm oder 75kOhm, je nachdem welche Ausgangsspannung benötigt wird(es würden auch bedrahtete gehen, ist dann halt nicht so schick)
– alles was man zum Löten braucht + etwas Geschick

Und so muss man vorgehen:

Auf der Unterseite der Platine in der Nähe des Konverters(der sich auf der Oberseite befindet) sind 2 SMD-Widerstände, diese sollen ausgetauscht werden.

Widerstände
Konverter

schaltplan

Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert




Enter Captcha Here :